UA-17470720-3

Jump to content


Photo
- - - - -

Setting y origin in Detail View

cells view-controllers

  • Please log in to reply
8 replies to this topic

#1 David DelMonte

David DelMonte

    Forum Master

  • STV 4.0 Pro
  • PipPipPipPipPipPipPip
  • 527 posts
Reputation: 41
Excellent

Posted 27 January 2015 - 02:47 PM

I have two apps, their detail views are auto-configured.

 

One shows a y origin of 99 - the other 35.

 

The latter is stuck under the Header:

 

Attached File  Screen Shot 2015-01-27 at 5.43.37 PM.png   9.51K   7 downloads

 

Did I do something? Can I fix it?

 

A difference between them is that the problem cell is normal, but has a master cell of Expand.Contract. (Red Herring?)



#2 ozie

ozie

    ¯\_(ツ)_/¯

  • STV 5.0 Pro
  • PipPipPipPipPipPipPip
  • 526 posts
  • LocationAustralia
Reputation: 169
Popular

Posted 28 January 2015 - 12:40 AM

under the header?? or under the navigationbar??

what version of STV are you using?? there was a problem or bug or something when tables where set to extend under bars


P.S. I hate Swift.. don't talk Swift.. Too old school to learn yet another programming language.


#3 David DelMonte

David DelMonte

    Forum Master

  • STV 4.0 Pro
  • PipPipPipPipPipPipPip
  • 527 posts
Reputation: 41
Excellent

Posted 28 January 2015 - 04:00 AM

Sorry. Nav bar. It's also only on the iPhone, not the iPad. There was a topic on this a while back - it pointed to an iOS 7 problem. I'm using 8. And STV 4.1.0. That topic is here. Do I still have to do this?


Edited by David DelMonte, 28 January 2015 - 04:06 AM.


#4 ozie

ozie

    ¯\_(ツ)_/¯

  • STV 5.0 Pro
  • PipPipPipPipPipPipPip
  • 526 posts
  • LocationAustralia
Reputation: 169
Popular

Posted 28 January 2015 - 04:12 AM

do you have seperate storyboard for the iphone and ipad or both in one??

 

i would try tracking and checking setting in the storyboard or in code first 


P.S. I hate Swift.. don't talk Swift.. Too old school to learn yet another programming language.


#5 David DelMonte

David DelMonte

    Forum Master

  • STV 4.0 Pro
  • PipPipPipPipPipPipPip
  • 527 posts
Reputation: 41
Excellent

Posted 28 January 2015 - 04:23 AM

I'm losing it...   @Ozie, you and I gave the answer to this a year ago:

 

- open the storyboard

- select the Controller

- open the Attributes Inspector

- in the Simulated Metrics section for Top Bar, change "Inferred" to "Opaque Navigation Bar"

- in the View Controller Section for Extend Edges, uncheck the check box for "Under Top Bars" 

 

Rebuild.



#6 ozie

ozie

    ¯\_(ツ)_/¯

  • STV 5.0 Pro
  • PipPipPipPipPipPipPip
  • 526 posts
  • LocationAustralia
Reputation: 169
Popular

Posted 28 January 2015 - 04:40 AM

i have under top bars ticked and my first cell is not half hidden under the nav bar.. so i think you some how have something going on


P.S. I hate Swift.. don't talk Swift.. Too old school to learn yet another programming language.


#7 David DelMonte

David DelMonte

    Forum Master

  • STV 4.0 Pro
  • PipPipPipPipPipPipPip
  • 527 posts
Reputation: 41
Excellent

Posted 28 January 2015 - 05:57 AM

ok. I'll look some more. Thanks..



#8 Tarek

Tarek

    Forum Admin

  • Administrators
  • 3670 posts
Reputation: 452
Popular

Posted 29 January 2015 - 04:16 PM

This was an iOS 7 issue a while back and we fixed it a long time ago. Would you try adding this to your view controller's viewDidLoad and let me know if it helps (at it at the very end of viewDidLoad in case you're setting it yourself indirectly somewhere in the middle):

 

self.edgesForExtendedLayout = UIRectEdgeNone;


#9 David DelMonte

David DelMonte

    Forum Master

  • STV 4.0 Pro
  • PipPipPipPipPipPipPip
  • 527 posts
Reputation: 41
Excellent

Posted 30 January 2015 - 10:01 PM

That works Tarek. Thanks again.







Also tagged with one or more of these keywords: cells, view-controllers

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users