UA-17470720-3

Jump to content


Photo
- - - - -

Upgraded to Xcode 7.1 - Error


  • Please log in to reply
3 replies to this topic

#1 designwerks

designwerks

    Advanced Member

  • STV 5.0 Std
  • PipPipPipPipPip
  • 139 posts
  • LocationKingsville, Ontario, Canada
Reputation: 23
Excellent

Posted 22 October 2015 - 07:01 PM

Just updated my Xcode to 7.1 as I needed to work with my iPhone which was updated to iOS9.1 (now that is working again)...

 

Getting an error now "The document"iPhone.storyboard" could not be opened. Failed to unarchive element named "SC_ArrayOfObjectsSection".  Edit this document with a newer version of Xcode.

 

Any ideas?



#2 Dave Guerin

Dave Guerin

    Forum Master

  • STV 5.0 Pro
  • PipPipPipPipPipPipPip
  • 541 posts
  • LocationIreland
Reputation: 134
Popular

Posted 22 October 2015 - 07:39 PM

Hi designwerks,

 

You need to run the InstallSTVXcodeIntegration.command script that came with STV 5.1.3 and then restart Xcode. I'd suggest also deleting DerivedData before starting Xcode.

 

STV 5.1.3 looks to have issues with ~customProperties http://sensiblecocoa...ies/#entry12961 and I'm currently running STV 5.1.0 code with STV 5.1.3 Plugins with Xcode 7.1 and iOS 9.1.

 

HTH


  • Tarek and designwerks like this
Cheers,

Dave

www.dgapps.ie

#3 designwerks

designwerks

    Advanced Member

  • STV 5.0 Std
  • PipPipPipPipPip
  • 139 posts
  • LocationKingsville, Ontario, Canada
Reputation: 23
Excellent

Posted 23 October 2015 - 03:35 AM

Thanks Dave,

 

It works after I ran the Install STVXcodeIntegration.command  - I was in a hurry last week and merely added the new 5.1.3 files to my project without integrating them... all good...

 

John



#4 Tarek

Tarek

    Forum Admin

  • Administrators
  • 3670 posts
Reputation: 452
Popular

Posted 26 October 2015 - 02:48 PM

For anyone else that gets this error in the future:

 

a. Make sure you download the latest version of STV. Each new Xcode version comes with a new compatibility UUID that we have to add to STV's plugin and release it as a new STV version. Apple does this to ensure that all plugins are updated and tested for compatibility before they are allowed to run on its new Xcode version.

 

b. Make sure you run 'InstallSTVXcodeIntegration.command' as per STV's user manual Installation section.


  • designwerks likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users