UA-17470720-3

Jump to content


Photo
- - - - -

Keyborad behavior on ipad


  • Please log in to reply
10 replies to this topic

#1 Enric Izquierdo

Enric Izquierdo

    Jr. Member

  • STV 2.0
  • PipPip
  • 22 posts
Reputation: 1
Good

Posted 19 April 2011 - 06:21 AM

Hi Tarek,

I've sent you a sample in order to test if is normal this keyboard behavior.

I'll try to explain.

In a tabBar app on ipad designed to work on portrait mode if the ipad is on plain surface when keyboard appears tableView hides some cells like this picture
Posted Image

but if I catch the ipad, just with some inclination or in vertical position, the keyboard is showed without hide any cell. I show you in this picture
Posted Image

Thanks in advance.

Enric

#2 Tarek

Tarek

    Forum Admin

  • Administrators
  • 3670 posts
Reputation: 452
Popular

Posted 19 April 2011 - 10:59 PM

Hi Enric,

Thank you very much for taking the effort to create us a sample app to replicate the issue, this has helped us tremendously. It does turn out to be a bug in the algorithm that resizes the table views for the iPad. We've got the bug fixed for our next STV 2.0.4 release (due in a few days). I'll now send you the updated sample app so that you'd confirm the bug fix. Thanks again! :)

#3 Enric Izquierdo

Enric Izquierdo

    Jr. Member

  • STV 2.0
  • PipPip
  • 22 posts
Reputation: 1
Good

Posted 20 April 2011 - 03:12 AM

Hi Tarek,

Thanks for your quick response.

I've tested the updated sample app and now the bug effect is inverse.

In a plain surface works fine but with some inclination the bug appears.

Thanks,

Ernic

#4 Tarek

Tarek

    Forum Admin

  • Administrators
  • 3670 posts
Reputation: 452
Popular

Posted 21 April 2011 - 06:07 PM

Hi Enric,

You're right! In our initial testing it was fine, but there seems to be a "tipping-point" where it gets reversed. We'll work on it and provide you with a fix ASAP.

#5 Tarek

Tarek

    Forum Admin

  • Administrators
  • 3670 posts
Reputation: 452
Popular

Posted 21 April 2011 - 09:47 PM

Hi again Enric,

Just sent you another update. Please confirm that's it's working well now. Thanks a lot!

#6 Enric Izquierdo

Enric Izquierdo

    Jr. Member

  • STV 2.0
  • PipPip
  • 22 posts
Reputation: 1
Good

Posted 22 April 2011 - 01:50 AM

Hi Tarek,

Fantastic job !!

It seems to work fine. Waiting for your next STV 2.04 release

Thanks again.

Enric

#7 Tarek

Tarek

    Forum Admin

  • Administrators
  • 3670 posts
Reputation: 452
Popular

Posted 23 April 2011 - 11:53 AM

Thanks for your feedback Enric :) Our further tests does confirm that it's working well. Thanks again!

#8 Enric Izquierdo

Enric Izquierdo

    Jr. Member

  • STV 2.0
  • PipPip
  • 22 posts
Reputation: 1
Good

Posted 24 April 2011 - 12:29 PM

Hi Tarek,

I've sent you another sample based on MultipleDetailViews sample from Apple in order to check these strange behavior when splitView is on landscape mode.

On simulator tableView scrolls fine showing the last textField or textView.
Posted Image

But in device running IOS 4.3 tableView doesn't scroll and the keyboard hides the cells.
Posted Image

Thanks,

Enric

#9 Tarek

Tarek

    Forum Admin

  • Administrators
  • 3670 posts
Reputation: 452
Popular

Posted 26 April 2011 - 10:33 PM

Hi Enric,

Thanks again for creating a sample app for us, that's really kind of you! :)

We're now finalizing the STV 2.0.4 release, and we've actually completely rewritten a big part of the table view resizing algorithm. I'll send you now a pre-release copy, please tell me if it's working well for you. You hopefully shouldn't face any more issues with table view resizing! :)

#10 Enric Izquierdo

Enric Izquierdo

    Jr. Member

  • STV 2.0
  • PipPip
  • 22 posts
Reputation: 1
Good

Posted 27 April 2011 - 05:19 AM

Hi Tarek,

Great job again !!

In my tests it seems to work fine.

Thank you very much for your awesome support.

#11 Brendan Duddridge

Brendan Duddridge

    Advanced Member

  • STV 5.0 Pro
  • PipPipPipPipPip
  • 170 posts
Reputation: 7
Good

Posted 29 April 2011 - 03:03 PM

Hey Tarek,

I am having the same problem too, but on an iPhone.

Would you mind sending me the update too please?

Thanks!

Brendan




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users